Modern Metal Golems Addon

Mods
17,824 Downloads Last Updated: Sep 6, 2016 Game Version: 1.10.2  

 

*** THIS MOD HAS MOVED! ***

Modern Metal Golems are automatically added when using Modern Metals, Base Metals, and Base Metal Golems together. Head over there to download. Thank you!

If you're ok with playing less-cool versions of Minecraft, Modern Metal Golems Addon adds the following to the Minecraft Universe:

V3.05.1+

  • Aluminum Golem: 40 health, 2.6 attack
  • Aluminum Brass Golem: 49 health, 3.3 attack
  • Cadmium Golem: 26 health, 4.5 attack
  • Chromium Golem: 36 health, 6.3 attack
  • Iridium Golem: 38 health, 4.6 attack
  • Magnesium Golem: 38 health, 4.6 attack, lights fires randomly
  • Manganese Golem: 33 health, 5.3 attack
  • Osmium Golem: 32 health, 4.8 attack
  • Plutonium Golem: 100 health, 5 attack, poisons nearby creatures
  • Rutile Golem: 16 health, 9.6 attack
  • Tantalum Golem: 160 health, 9.6 attack
  • Titanium Golem: 168 health, 10.6 attack
  • Tungsten Golem: 106 attack, 6.9 attack
  • Uranium Golem: 110 health, 5.5 attack, poisons nearby creatures
  • Zirconium Golem: 44 health, 5.3 attack

V4.03.1+

  • Galvanized Steel Golem: 116 health, 10.4 attack
  • Nichrome Golem: 120 health, 8.5 attack
  • Stainless Steel Golem: 165 health, 12.5 attack

 You can customize each golem's health, attack damage, spawn permissions, and any special abilities!

Sample config entry:

uranium_golem {
    # Whether the Uranium Golem can be built [default: true]
    B:"Allow Golem"=true

    # Whether this golem can poison nearby creatures [default: true]
    B:"Allow Special: Poison Creatures"=true

    # Base attack damage dealt by this golem [range: 0.0 ~ 300.0, default: 5.5]
    S:"Golem Attack"=5.5

    # Max health for this golem [range: 0.0 ~ 999.0, default: 110.0]
    S:"Golem Health"=110.0
}

Requirements:

Extra Golems -- the version number of the Modern Metal Golems download will match the Extra Golems version it was built for (eg, Modern Metal Golems 3.05.x requires Extra Golems 3.05)

V3.x require Modern Metals 0.10.1 and Forge for 1.8.9 (built and tested with version 11.15.1.1722)

V4.x, 5.x, and 6.x require Modern Metals 0.11.0 and the recommended version of Forge