FabricProxy-Lite

Mods
6,425 Downloads Last Updated: Nov 30, 2021 Game Version: 1.18   +2

Same as FabricProxy but only support Velocity and uses Fabric-API to handle velocity packet.

This one will have better compatibility with other mods.

Important

  • LuckPerms needs to enable hackEarlySend in the config.
    Because Fabric-API can't send packets before QUERY_START event, so player info(UUID) will not be ready at QUERY_START event.
    Enable hackEarlySend will use mixin for early send packet to velocity.

Setup

1. Download the mod and put it into mods folder
2. Start server to generate config
3. Setting velocity player-info-forwarding-mode to modern and forwarding-secret
4. Setting secret in config/FabricProxy-Lite.toml match velocity config

Report Issue

If you have reached something wrong, like mod compatibility or login problem, please follow the steps below:

1. Search for the issue, find out if there's already have one. You can also add some additional info you got.
2. If there's no such issue match to yours, create an issue ​by clicking the "New issue" button.
3. Summary the problem and write it into the title, then describe the issue as detailed as you can and make sure to provide any of the logs so we can know what's really happened.
4. Check again the whole things you have wrote, use the preview feature to check the composing.
5. Select a or multiple labels if you know what it means. The label isn't required to complete the issue and can leave it empty.
6. Submit the issue and make sure you can get the notification from this.

We thank all contributions you made, thank you!

如果你比較熟中文的話,也歡迎你用中文回報問題喔 ;)

Comments

  • To post a comment, please or register a new account.
Posts Quoted: