SoulsCrafter 1.2.0
Curse Maven Snippet
What's new
SoulsCrafter updated to 26.2
Requires: Minecraft 26.2 - Fabric Loader 0.19.3+ - Fabric API 0.154.0+26.2 - Java 25
All Relations
- All Relations
- Embedded Library
- Optional Dependency
- Required Dependency
- Tool
- Incompatible
- Include
This mod has no related projects

