Mixin 0.7-0.8 Compatibility

Mods
199,362 Downloads Last Updated: Aug 29, 2020 Game Version: Forge

All this mod does is load 0.8 mixin before any other mod is loaded, that's it. This is required for mods using 0.7 mixin to work correctly and predictably. It does this by loading first (having a name that gets sorted first), and loading 0.8 mixin.

 

Who should use this mod?

This mod should be added to a modpack if one or more of the mods use Mixin, and of different versions and if minecraft crashes on loading into the game, such as "An unexpected issue occurred and the game has crashed. We're sorry for the inconvenience. Exit Code: 0". Or the log contains "java.lang.ClassNotFoundException: net.minecraft.client.main.Main".

 


 

Idea suggested by KandiPanda, and requested by MineCrak

Comments

Posts Quoted: