header

Description

Roughly Enough IDs is a fork of JustEnoughIDs to maintain compatibility for additional mods.

Roughly Enough IDs is a lightweight mod that removes the block, item, biome, potion, and enchantment ID limits by using the 1.13 chunk format in 1.12.

More specifically, it uses a blockstate palette when saving chunks to NBT, and uses an int biome array rather than a byte biome array. There should be very few incompatibilities with other mods, but in case you find one, please report it to the issue tracker.

Unlike NotEnoughIDs, removing a mod from your modpack is supported, and won‘t cause corruption of the worlds created with that mod.

Extremely important: Removing Roughly Enough IDs will break your world!

Note: Tools such as World Painter will likely not work with REID worlds should they attempt to alter biomes.

Currently supporting:
- (since 2.0.8) Compatibility with CubicChunks (1.12.2-0.0.1271.0). REID now requires MixinBooter.
- (since 2.0.6) Partial compatibility with Astral Sorcery. Rewrites MixinEnchantmentHelper to avoid using @Overwrites to offer better compatibility with other coremods.
- (since 2.0.5) Compatibility with worlds created with NotEnoughIDs. Worlds will be converted and NotEnoughIDs is no longer required.
- (since 2.0.3) Compatibility with Realistic Terrain Generation Unofficial.
- (since 2.0.2) Compatibility with CubicChunks (1.12.2-0.0.1208.0). Allowing you to have both infinitely tall worlds, & infinitely large Item, block & biome IDs!
- (since 2.0.0) Compatibility with certain builds of The Twilight Forest.

Roughly Enough IDs should work perfectly fine in place of JustEnoughIDs. However, due to the nature of it being a fork, issues that are not present in JEID might occur in REID.