Pawn

Addons
43,018,557 Downloads Last Updated: Dec 3, 2020 Game Version: 9.0.2

File Details

Filename Pawn-2.4.6.zip
Uploaded by TravisSpomer
Uploaded Nov 17, 2020
Game Version 9.0.1
Size 749.61 KB
Downloads 794,354
MD5 f54d27c16c0c1fc16fcae6cfec77d703
Supported WoW Versions
9.0.1

Changelog

Version 2.4.6

  • Pawn will no longer appear as "out of date" after updating to WoW 9.0.2.

Version 2.4.5

  • WoW Classic: In Russian, shadow spell damage is now properly recognized on items. (This problem didn't affect other schools of magic or other languages.)

Version 2.4.4

  • Pawn's bag icons should now cooperate with Can I Mog It?'s bag icons again. Special thanks to the author of that addon, who inspired a much simpler solution that what I had come up with.

Version 2.4.3

  • Pawn now has a more complete set of gem recommendations, including new gems from the Shadowlands. For example, for resto shamans on an ilvl 100 item, Pawn will suggest five different +4 crit gems from different expansions, so you can buy the one that's cheapest.
    • This is just new recommendations, not a new feature—there still isn't a way to further customize gem quality levels to your exact tastes, but that's still on the to-do list.
  • Pawn was a little overzealous in resetting data that might have been affected by the level squish, so I've changed the way it works to be less annoying for people who have a lot of alts.

Version 2.4.2

  • Pawn's bag arrows integration will no longer work by default with custom bag addons.
    • The game no longer allows customizing that functionality while in combat, so before this change, Pawn's bag arrow integration caused errors while performing certain actions in combat, such as swapping weapons from the character sheet. Disabling support for custom bag addons is unfortunately the only way I can work around this.
    • To work around this, custom bag addons that call IsContainerItemAnUpgrade directly can use PawnIsContainerItemAnUpgrade when available instead, falling back to IsContainerItemAnUpgrade if it's nil. Then Pawn will control the bag arrows like it did before.
  • Pawn will now show two-handed weapons as potential upgrades for two-handed Frost Death Knights. If you're all about the dual-wielding life and want to turn this back off, you can go to Pawn's Values tab, select "Axe: 2H" (or any other 2H type) under "Weapon types", and then select "Don't show upgrades for 2H items."
  • You should no longer see a warning message about addon compatibility when playing on Russian WoW 9.0.

Version 2.4.1

  • WoW Classic: Hopefully fixed an error that occurred when turning in a quest.

Version 2.4

  • Welcome to WoW 9.0 and the level squish! Pawn had to wipe its memory of everything it knew about your characters before the squish since none of that information is correct anymore, so for a little while it might show you upgrades that aren't actually upgrades until it learns about your sweet epics. This shouldn't last long, and will automatically resolve itself as you play.
    • This version is meant for WoW 9.0 (Shadowlands pre-patch) and WoW Classic only.
  • Pawn should give reasonable gem recommendations and calculations in this version, but I'll continue to refine them in the coming days to give more helpful suggestions at lower levels.
  • Default stat weights have not been updated. Players participating in high-level raiding may want to import custom weights from a simulator instead of using the built-in guidance.
  • The Corruption stat has been removed, since it no longer has any effect on your character and appears greyed out.
  • Fixed a problem where if a quest gave you a useful item and a junk item (such as a gray artifact power item from Legion), Pawn would sometimes fail to show upgrade arrows on the non-junk item.