OPie​

Addons
2,201,127 Downloads Last Updated: Dec 15, 2019 Game Version: 8.2.5

Inconsistent profession activation

#264 By  FlesHBoX

Created Sep 26, 2019 Updated Dec 13, 2019

Closed
Fixed
Accepted
Blizzard bug

Since the 8.2.5 update professions will sometimes not open from oPie.  I've tried enabling debug but get no error messages.  I am using the default professions ring as a child ring of a custom ring I created.

It seems as though it's not specific to a certain profession (though I have seen it most often with tailoring, but this may be because I have 3 tailors).  Sometimes it will work fine, other times it will just not work at all.  It does not seem to alter during a play session, so if I log onto a tailor, it will not work, but if I log off and back on onto that tailor some time later, or a different tailor, it will work fine.

I have attempted to add a new slice for the profession that I'm having issue with, and it displays the same behavior.

 

Is there anything I can provide that might make it easier to reproduce?

Sep 26, 2019

The default professions ring attempts to open profession windows by doing the equivalent of /cast Tailoring. You should be able to verify the exact command it uses by running this macro before interacting with the ring: /run local f=CreateFrame("Frame"); f:RegisterEvent("EXECUTE_CHAT_LINE"); f:SetScript("OnEvent", print);

 

While OPie is failing to open tailoring, it might be interesting to check whether manually using /cast Tailoring works, and whether the issue persists after you /reload

Sep 26, 2019

This is a WoW client issue: in response to /cast Tailoring, WoW is attempting to cast the wrong "rank" of the profession, which doesn't open the profession window. You should probably report this to Blizzard after verifying that even without addons, manually typing in /cast Tailoring (or any other profession) can fail to open the right window.

 

I don't have a convenient workaround for this. One option would be to rewrite OPie's macro to use /cast spell:id syntax with the appropriate ID, but this would require updating when you learn different profession ranks.

cfxfox   added the tags
Accepted
Blizzard bug
  Sep 26, 2019
Sep 26, 2019

Edit: It seems a new response was added while I was typing this. I will take the advice above and open a bug report.

 

I, too, am having a similar problem with Engineering. The button was working previously (a long time ago) but now it does not. When I investigated, I did see it said /cast Engineering when I investigated. Now that I've removed and readded it,

 

When I run the script above it returns:

/click AB!18 116

 

It appears this is a WoW thing rather than an OPie thing, as typing /cast Engineering fails even in chat, while /cast Alchemy works. So it could be that the tradeskill "spells" were removed or renamed?  I'm not really certain, as I'm out of my depth, and people with more experience might have a better explanation.

 

 

Edited Sep 26, 2019

Sep 26, 2019

Aha, thanks for the update.  I confirmed that /cast Tailoring also does not work.  I'll submit a bug with Blizzard.

 

BTW, this is my #1 "Can't live without" addon.  I love all the work you've done to make my life a little better :)

Sep 30, 2019

Unless Blizzard has made a major change in 8.2.5, the addon Skillet opens professions using CastSpellByName(string) and has never had problems switching between professions. I'll run through my characters on 8.2.5 and make sure nothing has changed.

Sep 30, 2019

Blizzard is fucking with us in 8.2.5! I'm getting this error on random switches between professions. If I log off and log on again (same character), the problem is gone.

Oct 14, 2019

Added a workaround for this in W5.

cfxfox   added a tag
Fixed
  Oct 14, 2019
Dec 12, 2019

If you try, instead of /cast engineering, /cast Gnomish Engineer, it always works.

Also, if you try /run CastSpellByName("Engineering") you get a pop-up error window

with a message along lines of "A macro script was blocked from performing an act limited to the Blizzard UI".

 

I wonder why Bliz felt the need to screw around with something that has worked just fine for over a decade - likely since launch of WoW?  /argh >,<

Dec 13, 2019

> If you try, instead of /cast engineering, /cast Gnomish Engineer, it always works.

 

This should not be necessary within OPie; a simple /cast Engineering (or the Engineering spell slice) invoked from an OPie ring should always work -- open a fresh ticket if it doesn't. Since W5, OPie rewrites profession casts to a different casting mechanism internally so that you don't have to bother with it.

 

 

> I wonder why Bliz felt the need to screw around with something that has worked just fine for over a decade - likely since launch of WoW?  /argh >,<

 

It's simply a consequence of a bug in spell name/rank resolution logic; similar stuff has been happening to Travel Form for the past two expansions. Software is complicated, and they evidently can't and don't QA every corner of their macro-handling code. I would suggest complaining loudly on the official forums -- as there are few multi-rank spells left in the game, and there isn't much reason to macro professions while using the default UI, it's likely that they aren't even aware this is broken.


To post a comment, please login or register a new account.