Garrison Mission Manager

Addons
18,442,342 Downloads Last Updated: Dec 7, 2020 Game Version: 9.0.2

Fix for 9.0.1 (Shadowlands)

#89 By  spiralofhope

Created Oct 5, 2020 Updated Nov 4, 2020

Closed
Assigned to  rowaasr13
Fixed
Defect
spiralofhope   added a tag
Defect
  Oct 5, 2020
Oct 14, 2020

I can verify that GarrisonMissionManager does not work at all with the Shadowlands pre-patch.

Oct 14, 2020

Anyone have an alternative addon? Doesn't seem like this is going to be updated with over a year of no updates despite requests.

Oct 14, 2020

Hopefully aznamir's fix works.. I haven't had time to examine and test it.

Oct 14, 2020

 the fix by aznamir worked for me.

Thank god I love this addon

Oct 15, 2020

This is awesome!!!

Oct 17, 2020

 I can confirm the linked update from spiralofhope works.

Oct 17, 2020

I can also confirm it works without any lua errors.

Oct 17, 2020

Thx!!

 

works wirh 9.0.1

Oct 19, 2020

Aznamir solutions worked for me when open the zip and copy the file GarrisonMissionManager that  has the files named +Devel, Broker, in general lua files etc and then in the same file I copy MasterPlan and MasterPlanA .

 

I don't know if I can add a picture of how the file is ….

 

 

Oct 19, 2020

 MasterPlan is a separate addon, I've included it by mistake.

Oct 19, 2020

Thanks for the fix, works fine.

Oct 23, 2020

Works very well, thank you.

Oct 24, 2020

Edit - So this does appear functional but only if you have missions in which you can achieve at least 100% success in. If you still have a follower available but cannot pass 100% (i.e. 65%) on any available missions the buttons will be blank and non-functional.

 

Still does not work for me, game thinks addon is out of date and buttons on Bfa mission table don't have percentages over them nor pull in followers/recruits.

 

 

Edited Oct 25, 2020

Oct 25, 2020

would be great if we could get the "fix" pushed to curse.  Not sure what the hurdles or avenue for doing so is, but at current depending on which updater I use, it either stops showing up period, or shows as needing an update and updating overwrites the "fix"

 

Oct 28, 2020

The issue I'm noticing is that for characters who (with the new levelling system) are levelling through Legion and do not have a WoD Garrison are getting an error.  It looks like either the game or the add-on are looking for the WoD garrison pages (erring out as they don't have one).  The error pops up whenever you try to access the mission table or view status with the mini-map icon.  

 

Not sure if anyone else is seeing or if there is a fix but thought I would flag it up.  

Oct 28, 2020

 The new files do fix it and get it running again as normal, the only issue I see remaining is to edit the game version part to 9.0.1

 

 

Oct 29, 2020

I tried the "fix" and it did not work.  Any suggestions?

Oct 31, 2020

It broke with some of the latest updates again, sadly

Oct 31, 2020

 Does not work. Tested it today. 10/31/20

Nov 1, 2020

 The fixed version works fine. Make sure your addon manager hasn't re-installed the old version back.

@Roadskii  @Bellaente

Nov 3, 2020

9.0.1 support released in alpha. Release will follow in several days.

https://www.curseforge.com/wow/addons/garrison-mission-manager?comment=1184

 

@DapperH2 please fill as separate issue, I'll be fixing it.

rowaasr13   added a tag
Fixed
  Nov 3, 2020
Nov 4, 2020

 Thank you!

 


To post a comment, please login or register a new account.