Real Tech

Modpacks
6,341 Downloads Last Updated: Nov 16, 2019 Game Version: 1.12.2

Game crashes on startup

#19 By  Tianyulong

Created Mar 25, 2019 Updated Sep 20, 2019

Closed
Mod Bug
Tianyulong   added a tag
Pack Bug
  Mar 25, 2019
Mar 31, 2019

Thanks for the report. This is a strange crash as it seems to be a java crash rather than a game crash. I've seen a couple other people having this issue. I haven't though, so I haven't been able to troubleshoot directly. Let me know if you still continue to get the crash with the latest version of the pack (2.3.7). If so, if you could let me know at what point during the boot process the crash occurs, that would be helpful. Also, I'd recommend making sure you're running the latest version of Java and that you make sure Minecraft is using that version (in the Twitch app Minecraft settings using the JAR Launcher rather than the Native Launcher).

Mar 31, 2019

The update from 2.3.6 to 2.3.7 seems to have fixed the crash for now. I'll let you know if anything else pops up!

 

Edit: Scratch that, I started getting the crash again. I've gotten multiple blue screens of death while playing your pack, I wonder if that's related or a coincidence?

Edited Mar 31, 2019

Apr 3, 2019

 @Tianyulong do you get any other log besides the crash log? Does it crash when you're starting/loading the pack, or when you're playing? Any more info you can give?

Apr 3, 2019

It crashes about halfway through loading up the pack. I got a log file from the last time I tried to boot up the pack, I hope this is helpful. https://pastebin.com/hZegb8cX

Apr 3, 2019

Interesting. Looks like it might be foamfix. I'd be curious to see if the problem goes away if you remove that mod. You may have an increase in lag spikes without it, but if it fixes the crashes, that will help narrow down the problem.

Apr 4, 2019

Yeah, disabling foamfix does fix the crash. What an odd situation, I've never had issues with Foamfix before. Oh well, my computer can handle the lag spikes. I hope a better solution is found in the future, but this is an acceptable workaround.

Apr 5, 2019

My guess is that there's some conflict between foamfix and another mod in the pack, most likely one that has custom models (maybe Immersive Petroleum?). I contributed to an issue on the foamfix issue tracker with your reports here: https://github.com/asiekierka/FoamFix/issues/194

 

If you don't mind doing a little more experimentation, could you re-enable foamfix and try tweaking some configs?

First, in the config/foamfix.cfg file, I'd like to see if disabling deduplicateModelBakers helps. If so, I'd like to know if re-enabling it, and then reducing the number for deduplicateModelsMaxRecursion helps.

 

Also, in the Twitch app Minecraft settings, are you using the Native Launcher or Jar Launcher?

Apr 7, 2019

@Tianyulong, can you repost a crash report? It looks like the one you posted has expired.

Apr 7, 2019

 Oops! Never mind. I just copy/pasted it incorrectly.

Apr 10, 2019

Hey, just wanted to say I haven't forgotten about this! I'm prepping for finals, so it'll be a bit before I can do extensive testing, but I did figure out a few things. I'm using the Native Launcher. I've started having troubles with Enigmatica 2 Expert as well after an update (what's even stranger is it will crash some times but not others), so it's clearly related to newer builds of Foamfix. What version exactly causes the crash I am not yet sure.

Edited Apr 10, 2019

Apr 11, 2019

This also happens to me, however, (Not sure if this was just coincidence or not) when I had the pack open (not tabbed out) it loaded.

 

EDIT= it just happened to be a coincidence, it seems to very rarely load, stopping at 3/7 of the loading

Edited Apr 11, 2019

Danny_and_Son   added a tag
Mod Bug
  Apr 13, 2019
Danny_and_Son   removed a tag
Pack Bug
  Apr 13, 2019
May 22, 2019

Hey, finals are finished so I'm ready to resume working on this issue. I tried out disabling deduplicateModelBakers like you suggested, but the crash still happened. Any other suggestions?

Jun 5, 2019

still getting crashes at boot on 6/6/2019 and it only fully loads 5/10 times very random, its always the same error tho being (failed to write core dump. minidumps are not enabled by default on client versions of windows)

not sure if there is a fix yet but can get very annoying, i have also managed to get a server working for the mod pack and as the creator said its very easy and there aren't even any conflicts

Edited Jun 5, 2019

Jun 5, 2019

I've been having the exact same problem with Enigmatica 2 Expert, weirdly just that pack and this one. But I feel like I can get Enigmatica working more consistently then Real Tech

Sep 20, 2019

I have removed Foamfix in 2.4.2 of the pack. The author hasn't responded to the issue for a long time, and it's not worth the performance improvements if it's preventing people from playing the pack.


To post a comment, please login or register a new account.