This site is currently in Read-Only mode for maintenance. Any changes will be prevented and the site may act unpredictable during this period

Netherlicious

Mods
2,959 Downloads Last Updated: Nov 22, 2020 Game Version: 1.7.10

Hell Biome ID Conflict

#11 By  yellowduck2020

Created Oct 24, 2020 Updated Nov 4, 2020

Closed
Not a Bug

I have Anti ID Conflict installed, and it crashes the game whenever I try to launch it due to a biome ID conflict:

 

code.elix_x.coremods.antiidconflict.managers.BiomesManager$BiomesIDConflictException: Conflict between biomes with same id caused game to crash.
Affected ids:
8 is asked by: Hell (net.minecraft.world.biome.BiomeGenHell), Hell (DelirusCrux.Netherlicious.Biomes.OverriddenBiomeNether)

 

I tried both removing the vanilla hell biome and replacing it with this new one using BiomeTweaker, but that didn't work. I assume it's because the biome ID is still assigned, regardless if the biome is supposed to generate or not.

I was wondering if it's possible to assign a different biome ID to the new hell biome and disable the vanilla hell biome in world generation.

Oct 24, 2020

Yeah this is normal, you can ignore this. This happens because I'm overriding the default nether biome. If I wouldn't do this, the default nether biome wouldn't generate, since I have to override the whole nether to even be able to inject my own biomes, since the default nether does not support biome generation.

 

Btw. If you have Biomes O Plenty installed too, I let BoP override the Nether Biome, since they add more generation to it.

 

 

 

There is an option in AntiIDConflict to stop it from crashing when it detects something like this.

DelirusCrux   added a tag
Not a Bug
  Oct 24, 2020
Oct 24, 2020

Ok scratch that. I'm changing it in the next version. I'll no longer override the default nether biome. turns out the way I did it, could cause some minor internal issues that didn't result in crashes or visible stuff. So next version should fix your crash too.

Nov 4, 2020

It's fixed now


To post a comment, please login or register a new account.