header

Flytre Lib (FlytreLib) will start downloading in 5 seconds...

STILL DOWNLOADING MANUALLY??

Join over 10 million players who use the CurseForge app!

Download App Now

Description


https://imgur.com/ikjJxIi.png

 

  FABRIC | FORGE

 

 

FlytreLib contains a bunch of utilities that make maintaining my mods much easier! It is not recommended for other mod authors to use the library as it is not backwards compatible and bound to rapid expansion and modification that can render old implementations totally redundant!

 

Features include a recipe API, fluid API, config API, and upgrade API, among many more.

 

Q: How do I reload configs without restarting the game?

A: For client side configs, pressing f3 + t to reload textures will also reload client configs. So will exiting and re-entering a world. F3 + Y is a custom keybind that will also instantly reload client configs.

    For server side configs, you can use the command /reloadconfig to reload them.

 

Q: This mod is crashing with mod Y!

A: I may offer support for other mods, but its at my discretion. I will never require an explicit dependency on another mod in order to fix a bug. I will not offer support for versions prior to the latest version.

 

Q: This mod crashes with mod loader Y!

A: I will never offer any support for other mod loaders besides Fabric and Forge unless this mod is explicitly ported to that loader. Even loaders which are so-called "compatible" with fabric or forge mods. 

 

Q: Do I need Fabric API?

A: No. However, some parts of this library do require fabric API to activate and mods which use those parts will explicitly require Fabric API themselves (for example, Hopper Plus). 

 

Q: Please update to version Y!

A: I will do that on my own time when I want to. Asking will not make it happen, and I will not provide sources to my mods for others to update. However, monetary compensation may help persuade me.