Fabric API is the core library for the most common hooks and inter-compatibility measures utilized by mods using the Fabric toolchain.
- Fabric’s APIs are lightweight and modular, making porting faster and game instances leaner.
- Fabric development targets snapshots as well as release versions, allowing earlier mod updates and more informed community planning.
- The Fabric toolchain is available for everyone to use - even if you only want to use some of it!
Fabric comes in two parts:
- Fabric Loader: Minecraft version independent, provides the essentials of mod loading and rudimentary modding
- Fabric API: Minecraft version specific, a mod like any other, provides all sorts of APIs for interoperability and convenience (this CurseForge project)
- Install Fabric Loader from the Fabric website - there is an installer for the vanilla launcher and dedicated servers, other launchers including the Curse App may do this automatically
- Optionally try to run the game to verify the installation and create the mods folder. There should be Fabric related log entries and the main menu will mention Fabric at the bottom next to the Minecraft version.
- Download Fabric API for the desired Minecraft version from this page and put the jar file in the mods folder like any ordinary mod
More information and full installation instructions can be found on the Fabric website and support is available through the Fabric discord server.
This is SEPARATE from the Fabric loader! You need both for most mods! Keep in mind the project requires the Fabric mod loader!
Popular previous versions can be found here:
hate y'all. the amount of mods that are all top 20 imo are split 66.66% forge, 33.33% fabric. God damn y'all why couldn't we all just stay on forge...
lets go i was the first download for 1.20 snapshot
WhaT If wE JuSt PoRtEd tHiS tO fOrGe?? tHen iT wOuLd bE eAsIEr tO pOrT fAbRiC mODs To foRgE rIgHt?
(If you couldn't tell, this is a joke.)
In reply to StormDragon_64:
You won the "most repeated unfunny joke that wasted everyone's time because it's outdated and no one cares anymore for it to even be worth reading it" award on this site as the ??? commenter. Congrats you earned it.
You also won a trip to the so called 'what is competition' vacation,
you won a 'wait we always had 2 modloaders over the years' history book,
a 'wait legacy fabric/cursed fabric exist' invitation to other projects tour,
a 'wait Patchwork/Forgework API used to exist' fortune cookie with the fortune being pretty unuseable,
a 'installing Fabric is so easy it requires just the Fabric API as an extra step who knew' cup of drinking simplicity,
and the 'mod authors code how they want to with their APIs and libraries on their terms' all you can eat meal, with all your favourite courses of breakfast, lunch, entrees, dinner and desert.
Your getting a better package then that other commenter that only got the first award you got an upgrade. :)
1.19.4 seems to not be compatible with carpet.
can you please make a 1.19.2 forge version
Can I have Fabric and Forge together?
In reply to styleblaizen:
Patchwork or Forgework API tried that with patching Forge mods to Fabric or I think the reverse but the project was abandoned. The modloaders are too different coding wise. But just pointing out a method attempted for 1.14.4 and 1.16.5 existed.
As an example the modpack that showcased how to (has been abandoned): https://www.curseforge.com/minecraft/modpacks/patchworkmc-testpack
Even Legacy Fabric exists on 1.3.2 to 1.13.2 versions, they aren't compatible either but still the Fabric mod authors do lots of different projects. The code may be different but the mod authors do find ways to do some cool things.
My Api version is 1.19.3, but the Fabric installer game version is 1.19.3, the loader version is 0.14.13, and the downloaded modules are also 1.19.3. But when I drag into the folder to load the game, he always jumps out the error reminder that the loader does not fit, saying what is the 1.50 version of my module, and my loader needs 1.40. x or higher, and I can't find anything else, 1.14.13 is the highest loader version I can find. What should I do?
模组后跳出来的游戏错误提示，该怎么解决呢？我加入mo'zu不兼容的模组集！不兼容的模组集！net.fabricmc.loader.impl.FormattedException：模组遇到分辨率不兼容的模组集！已经确定了一个可能的解决方案： - 安装 fabric-language-kotlin，版本 1.7.4+kotlin.1.6.21 或更高版本。- 安装 libipn，介于 2.0.2（含）和 3.0.0（不含）之间的任何版本。- 安装坏数据包，版本 0.3.3 或更高版本。未满足的依赖项列表： - mod“下一个清单配置文件”（清单配置文件下一个）1.9.2 需要 1.7.4+kotlin.1.6.21 或更高版本的 fabric-language-kotlin，这是缺失的！- mod“下一个库存配置文件”（下一个库存配置文件）1.9.2 需要 libipn 的 2.0.2（含）和 3.0.0（独家）之间的任何版本，这是缺失的！- Mod 'wthit' （wthit） 6.1.4 需要 0.3.3 或更高版本的坏数据包，这是缺失的！atnet.fabricmc.loader.impl.FabricLoaderImpl.load（FabricLoaderImpl.java：190）atnet.fabricmc.loader.impl.launch.knot.Knot.init（Knot.java：148）atnet.fabricmc.loader.impl.launch.knot.Knot.launch（Knot.java：68）atnet.fabricmc.loader.impl.launch.knot.KnotClient.main（KnotClient.java：23
In reply to gamingbever1:
Hello need any help?
In reply to SuntannedDuck2 evet
Hello, I have been trying to use the 1.19.3 version of fabric but it won't start. The error is: The game crashed whilst initializing game
Error: java.lang.RuntimeException: Mixin transformation of net.minecraft.class_338 failed
Does this mod work on forge?
In reply to athiccsadist:
What a bing chilling joke you got there, sir.
In reply to athiccsadist:
If serious then no it does not. Nor are Forgework API/Patchwork possible anymore to my knowledge (Fabric/Forge compat layers).
You earned the most over used joke in a modding community award. Wear it with pride you earned it not these other people using the same one, you are lucky to have posted it at this specific time you 1 millionth commenter you.
In reply to athiccsadist:
Aint no way someone asked that question
Hello, I need Fabric Loader version 0.67.0, but no matter what I do, it doesn't open. I tried all the methods, I installed the new Java version, but the installation page doesn't open, if you can help me.