Chunk-Pregenerator

Mods
13,618,916 Downloads Last Updated: Aug 3, 2022 Game Version: 1.19   +3

[1.16.5[ Retrogenerator issue

#147 By  mymomtookmyphone_

Created Sep 9, 2021 Updated Sep 10, 2021

Open

Testing the retrogenerator on a worldpainter world with no caves or ore. Not sure if it's broken but only specific features seem to work for the retrogen. I tried retrogenerating AE2 Certus Quartz, Create ore, RFTools dimensional shards and none of them seem to work. The only one that worked during retrogeneration is structures from the Tetra mod. I would appreciate if there's a way to fix this, or an explanation for what i'm doing wrong if I am doing something wrong. For reference here is the command i used for retrogeneration:

/pregen start gen radius retrogen3 SQUARE ~ ~ 16 minecraft:overworld RETROGEN

and the retrogeneration features i had enabled:

rftoolsdim:rftfeature
appliedenergestics2:charged_quartz_ore
create:create_config_driven_ore

Sep 10, 2021

Eh good question.

 

The problem here: this is hard to debug because every mod itself decides how it generates its own stuff.

All chunkpregen does is tell it to try generate stuff at chunk XYZ and the generator either does it or not.

On top of that the mod decides in which biomes each generator actually works in, so if the generator is not present in that biome then pregen can not force a generator to do something where it is not present.

 

:/ I am not sure how i can help you there :/


To post a comment, please login or register a new account.