Abnormals Core

Mods
1,298,156 Downloads Last Updated: Sep 23, 2020 Game Version: 1.16.1

Banner Minecraft Abnormals Discord Minecraft Abnormals Twitter MCA Patreon

📖 About

Abnormals Core is a mod library developed for easily accessing code which is shared across most Minecraft Abnormals mods without needing to copy classes across each project. This library is developed by SmellyModder (Luke Tonon) and bageldotjpg. It comes with many useful features, such as an easier way to automate registering blocks, items, etc, and the animation library called Endimator.

💻 For Developers

In order to use Abnormals Core in your mod, you need to add it to your build.gradle.

Curse Maven Plugin

In order to get the library from Curse, you'll need to add the Curse Maven plugin in your build.gradle.

After the buildscript section on the top of your build.gradle, paste in the following block:

plugins {
       id "com.wynprice.cursemaven" version "2.1.1"
}

Adding the Dependency

You'll next need to add Abnormals Core as a dependency on your project and tell Forge to deobfuscate it. In the dependencies block paste in the following:

implementation fg.deobf("curse.maven:abnormals-core:curseFileID")

The Curse fileId can be found on the end of the link of the file on CurseForge. For example, the fileId of 2954634 would add Abnormals Core 1.0.0 as a dependency.

Refresh Gradle

Once you've done the steps above, you now need to reimport the Gradle project. This can differ from IDE to IDE, so we can't give explicit details on how. On most IDEs, just follow the steps you would when setting up your mod environment.

Adding Abnormals Core as a Forge Dependency

You'll need to tell Forge that Abnormals Core is a hard-dependency for your mod, this means that Abnormals Core will be required to run your mod. At the bottom of your mods.toml file paste the following: [[dependencies.<modid>]] modId="abnormals_core" mandatory=true versionRange="[x.x.x,)" ordering="AFTER" side="BOTH" Replace <modid> with your mod's id of course. Set the versionRange to the version you chose on CurseForge.

That's it! You should now have Abnormals Core in your workspace and as a required dependency. Any issues you find should be reported to the Issue Tracker.

📦 Official MCA Mods

Wiki