• 0

    posted a message on Question: Taking over an outdated addon?
    Aura Frames has been fixed. Like Seerah says, I have put ARR on Aura Frames because I don't like clones in the same global namespace and that people come to me for random errors or anything like that.

    Also, if I choice to stop maintaining, people can contact me or I release the project on Curse.
    Posted in: Project Discussion
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from derevka
    This is what I keep getting:

    And the mouseover stays even when my mouse isnt over it. Despite me saying to Hide Blizzard aura frames.

    I've checked all my mods that manage buffs. (STUF Unit Frames, Tidy Plates, Power Auras) Any suggestions? In Fact it does it when AF is the only thing enabled and everything else is disabled.

    Edit: if I click on/click off the checkbox for Hide Blizzard Aura frames they go away... temporarily and come back. (though not at a seemingly obvious time, just sporadically)


    R339 should fix this problem forever now (after I'm done with hiding the default blizz buffs, there isn't even a show option left :P)

    Also, you can simply disable "Consolidate Buffs" in Main menu => Interface => Buffs and Debuffs.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from zyrqueda
    Hi there,
    the addon is really nice, but it does not show cooldowns for Holy Word Spells except for Holy Word: Chastise.
    This will probably happen due to the fact that within a chacra-state, the Holy Word Spells do not trigger the Cooldown seen within the caster's spellbook
    the spell ids:
    88625 (chastise)
    88684 (serenity)
    88685 (sanctuary)


    Added support for this in the last alpha.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from jellinn
    I'm using TimeLine mode.

    under Layout / Text / Time layout are the options:
    10m
    10 m
    615
    10:15
    10.15

    The last 2 are the options that seem like they should show tenths of seconds, but they do not show tenths of seconds in TimeLine mode.
    It shows the time of my cyclones as 0.05 at 5 seconds, 0.04 at 4 seconds... so on, there are no tenths of seconds being displayed.

    The tenths of seconds need displayed in order to be accurate. It seems like a bug to me that I'm hoping will be resolved and I was also hoping for some confirmation on this


    It was working at intended, the .xx is seconds. I added an option to display now also tenths of seconds.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from tordenflesk
    I was wondering why the "spark" seemed to move parts of the frame along with it.


    What do you mean? Got a screenshot or can you give a more detailed description?
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from Sigurdr
    Greetings!
    Thanks for good addon!
    Prompt please, you plan to add support for other languages through a bookmark Localization, as for example there?


    Maybe someday, but only the configuration contains text. So it isn't a high priority for me.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from Aranan
    There's something a little strange going on with ButtonFacade and Aura Frames. It seems like no matter what skin I use with ButtonFacade, the borders around Aura Frames are whiter and sometimes have a gloss even though I have that effect globally set at 0% opacity.

    Here are a few examples:
    Not_Caith: http://img864.imageshack.us/img864/1160/wowscrnshot041111095622.jpg

    Svelte: http://img34.imageshack.us/img34/7972/wowscrnshot041111095856.jpg

    Apathy: http://img34.imageshack.us/img34/1933/wowscrnshot041111095954.jpg

    In all cases, Bartender4 and SatrinaBuffFrames are skinning correctly, but Aura Frames isn't. Any clue what's going on?


    Aura Frames is always coloring borders for displaying different kind of debuffs. Even normal borders of normal buffs are colored.

    That's why there is a difference, maybe in a next release I will allow for no coloring.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from zyrqueda
    Hi there,
    the addon is really nice, but it does not show cooldowns for Holy Word Spells except for Holy Word: Chastise.
    This will probably happen due to the fact that within a chacra-state, the Holy Word Spells do not trigger the Cooldown seen within the caster's spellbook
    the spell ids:
    88625 (chastise)
    88684 (serenity)
    88685 (sanctuary)


    Thanks for pointing this out, I scan indeed the spell book and monitor those spells. I'm not a fan of adding static spell lists (that's why I still don't support internal trinket cd's for examle). But I can add maybe in the next version an ability to add custom spells to monitor so you can do this for your self.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from Tomber
    UnitAura includes isStealable as one of its return values (this is how Raven detects spell stealability for filtering and notification).


    My mistake indeed, I mixed up 2 different things. IsStealable is already tracked but was not enabled for the filter. In the last alpha I enabled it for the expert filter. Please try it and report back if its working.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from foreverphk
    Possible to add a stealable buff for mage's spellsteal?

    Thanks alot.


    This is already on my todo list, but it hasn't big priority, next to that, it seems not easy to implement. There isn't an easy way of detecting (efficient) what spell can be spell steal and which can't.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from H0PE
    Hi,

    Just swapped over from SFB (R.I.P.)... And starting with a question, or request if its not possible yet (so we can actually start ditching more addons, like Power Auras Classic LOL).

    -Is there a way to show non active buffs/debuffs on you/target/etc. (specified by spellid list maybe)?

    Thats what I'm trying to figure out then I can ditch Power Auras completelly, everything else your addon can do, which is INSANE IMBA!

    Thanks in advance


    This is something that can be supported maybe, but this will not be implemented soon anyway. There are a lot of things that need to be done first and atm I don't have that much time.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from gotenex
    +1

    It would also be awesome if you could add a check for primary/secondary spec.


    This is already supported, if you go to the profile section in the configuration then you can select an other profile for your secondary spec.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from Tikal696
    Hello Beautiuz.
    Is there a way to set the filter for a custom icd on a trinket for exemple ?
    Something like this :
    - if i've got the buff "Volcanic Destruction"
    - start a timer that act like a cooldown of 45sec


    No that is not possibly, maybe someday but not soon anyway
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from sp00n
    Yeah, I made that post here before I opened the tickets.
    But regarding a reloadui, I actually did try that. However my newly added containers were deleted upon reloading (and along with them the filters assigned for them of course).


    Could you try the last alpha, I fixed a few bugs in the configuration part but I didn't encounter the problem with that you can't save containers. In the last alpha I also can't reproduce it.
    Posted in: General AddOns
  • 0

    posted a message on Aura Frames - Official Thread
    Quote from sp00n
    Hm, filtering doesn't seem to work for me.

    I'm trying to do a Debuff Filter where only selected debuffs on the target are shown within a button frame, but no matter what I enter there, it just doesn't filter anything at all.
    Even switching to simple mode and checking "Not cast by me" doesn't change anything, still seeing my own debuffs.

    // Edit
    That was with r277 and newer (didn't check older than that). Reverted to the release version and it's working now.


    I saw you tickets, I'll look into in soon. I know that there is a problem is the last alpha at least that when you change a filter in the configuration that the filter changes are not applied. To work around, change the filters and the do a /reload
    Posted in: General AddOns
  • To post a comment, please or register a new account.