CurseForge

602 - Option to choose Release / Beta as default release on Curse.com

What is the enhancement in mind? How should it look and feel?

Since both Release & Beta versions of mods syndicate to curse.com, currently the latest release version is chosen for the big "DOWNLOAD" button at the top.

It would be nice to allow mod authors to choose to have beta versions defaulted.

User When Change
Ackis Jan 19, 2009 at 18:41 UTC

Changed status from New to Duplicate. Duplicate of 367 - Set a file as default.

Voorije Sep 17, 2008 at 19:33 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of Ackis Ackis Jan 19, 2009 at 18:42 UTC - 0 likes

    Yah I'm trying to keep tickets cleaned up, I want the mark as duplicate to work a bit better tbh, but that's how it is right now.

    BFAK:Ackis,90710388,2f62cbb4c100385c86df0c1418f5ac5a2cb1a2bc3f2a18f13291792dbb3a1480

  • Avatar of Phanx Phanx Jan 16, 2009 at 03:55 UTC - 0 likes

    I'd posted a new ticket recently, having forgotten about this one since it was ignored for so long, and mine was closed as a Duplicate, so I'll repost it here as a comment.

    Currently, when a file marked "beta" syndicates to Curse.com, it does not affect the "last updated" date, it does not notify users who've added the project to their favorites list that there is an update, it continues to give users who click the big fat Download button the older "release" version, and it gives no "above the fold" indication that any beta versions are available.

    For example, I've just finished rewriting one of my addons from scratch, and while the functional bits are all done, the GUI isn't done yet. Technically, I feel this should be labeled as a beta, since it is incomplete, but I also feel that it is ready for general usage, especially since the previous release version is crippled by a fundamental inability to properly support certain WoW 3.0 changes (in fact this is exactly why I rewrote it) and should not be used by anybody anymore. While I would love to get the GUI finished, the reality is simply that I do not have unlimited time to code. In this situation, with the site's current functionality, I can either mark new versions as "release" even though they shouldn't be, or I can mark them as "beta" and then answer dozens of PMs, emails, and tickets asking me to fix bugs that exist in the last "release" version because nobody has any idea that there are newer versions available.

    WoWInterface handles this situation by adding a visible "Beta" tab at the top of the page, where it is easily and quickly seen by users.

    An even better solution would be to add a project-level preference for allowing "beta" files to be the default download for the project. Then, users wouldn't even have to look (which is probably asking too much given that most of them don't read the bold text at the top of my description telling them to scroll down for the betas), just mindlessly click the Download button.

    For those voting this down, keep in mind that this would be an option at the project level. If you are never in a situation where it is appropriate for your project's default download to be a beta file, simply don't enable the option.

  • Avatar of Kane Kane Oct 19, 2008 at 16:49 UTC - 0 likes

    Agreed. I suggested the same in my ticket yesterday

  • Avatar of Phanx Phanx Sep 18, 2008 at 04:16 UTC - 0 likes

    Agreed. Currently, I never mark a version as "beta" because of this, unless EVERY version is a "beta".

  • 4 comments

Facts

Last updated
Mar 30, 2012
Reported
Sep 17, 2008
Status
Duplicate - This report duplicates an existing ticket.
Type
Enhancement - A change which is intended to better the project in some way
Priority
Medium - Normal priority.
Votes
5

Reported by

Possible assignees