CurseForge

1080 - Add Repository Log Viewer

What is the enhancement in mind? How should it look and feel?

I know at first glance it may seem a bit redundant, however when frequently working in branches on new versions of mods it would be nice to have a place that tech-savvy users could check the progress of a mod via the SVN/hg/git log without having to install svn/hg/git and check out/update the project frequently.

Additionally it would be nice to be able to link to revision changes i.e.

http://wow.curseforge.com/p/myproject/repolog/147

To call up r147's changelog when referencing various updates or documenting when tickets were taken care of and/or as points of discussion in general.

User When Change
Kaelten Jan 23, 2009 at 20:37 UTC

Changed status from New to Duplicate. Duplicate of 347 - Repository browser.

Reanmachine Jan 22, 2009 at 18:12 UTC Changed name from Add SVN Log Viewer to Add Repository Log Viewer

Changed description:
  What is the enhancement in mind? How should it look and feel?

- I know at first glance it may seem a bit redundant, however when frequently working in branches on new versions of mods it would be nice to have a place that tech-savvy users could check the progress of a mod via the SVN log without having to install svn/hg/git and check out/update the project frequently.
+ I know at first glance it may seem a bit redundant, however when frequently working in branches on new versions of mods it would be nice to have a place that tech-savvy users could check the progress of a mod via the SVN/hg/git log without having to install svn/hg/git and check out/update the project frequently.
  Additionally it would be nice to be able to link to revision changes i.e.
- http://wow.curseforge.com/p/myproject/svnlog/147
+ http://wow.curseforge.com/p/myproject/repolog/147
  To call up r147's changelog when referencing various updates or documenting when tickets were taken care of and/or as points of discussion in general.
Reanmachine Jan 22, 2009 at 18:11 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

Facts

Last updated
Jan 23, 2009
Reported
Jan 22, 2009
Status
Duplicate - This report duplicates an existing ticket.
Type
Enhancement - A change which is intended to better the project in some way
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees