Curse Client v4 - Windows

1524 - Error starting client, installing updated client

What steps will reproduce the problem?
1.  Start Client or
2. Attempt to re-install by downloading setup.exe
3.

What is the expected output? What do you see instead?

What version of the product are you using?

Do you have an error log of what happened?

PLATFORM VERSION INFO
    Windows             : 5.1.2600.196608 (Win32NT)
    Common Language Runtime     : 2.0.50727.3082
    System.Deployment.dll        : 2.0.50727.3053 (netfxsp.050727-3000
    mscorwks.dll            : 2.0.50727.3082 (QFE.050727-3000
    dfdll.dll            : 2.0.50727.3053 (netfxsp.050727-3000
    dfshim.dll            : 2.0.50727.3053 (netfxsp.050727-3000

SOURCES
    Deployment url            : http://clientupdate.curse.com/CurseClient.application

ERROR SUMMARY
    Below is a summary of the errors, details of these errors are listed later in the log.
    * Activation of http://clientupdate.curse.com/CurseClient.application resulted in exception. Following failure messages were detected:
        + The referenced assembly is not installed on your system. (Exception from HRESULT: 0x800736B3)

COMPONENT STORE TRANSACTION FAILURE SUMMARY
    No transaction error was detected.

WARNINGS
    There were no warnings during this operation.

OPERATION PROGRESS STATUS
    * [10/5/2009 2:56:35 PM] : Activation of http://clientupdate.curse.com/CurseClient.application has started.

ERROR DETAILS
    Following errors were detected during this operation.
    * [10/5/2009 2:56:35 PM] System.Runtime.InteropServices.COMException
        - The referenced assembly is not installed on your system. (Exception from HRESULT: 0x800736B3)
        - Source: System.Deployment
        - Stack trace:
            at System.Deployment.Internal.Isolation.IStore.GetAssemblyInformation(UInt32 Flags, IDefinitionIdentity DefinitionIdentity, Guid& riid)
            at System.Deployment.Internal.Isolation.Store.GetAssemblyManifest(UInt32 Flags, IDefinitionIdentity DefinitionIdentity)
            at System.Deployment.Application.ComponentStore.GetAssemblyManifest(DefinitionIdentity asmId)
            at System.Deployment.Application.ComponentStore.GetSubscriptionStateInternal(DefinitionIdentity subId)
            at System.Deployment.Application.SubscriptionStore.GetSubscriptionStateInternal(SubscriptionState subState)
            at System.Deployment.Application.SubscriptionState.Validate()
            at System.Deployment.Application.SubscriptionState.get_IsInstalled()
            at System.Deployment.Application.SubscriptionStore.CheckAndReferenceApplication(SubscriptionState subState, DefinitionAppId appId, Int64 transactionId)
            at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
            at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS
    No transaction information is available.

Please provide any additional information below.

User When Change
Adamar Oct 05, 2009 at 21:07 UTC Changed status from New to Verified
rhldr Oct 05, 2009 at 20:59 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of rhldr rhldr Oct 06, 2009 at 13:51 UTC - 0 likes

    Removing via control panel did not work, but your app store instructions worked. You may also remove bug 1540 which is a duplicate

  • Avatar of Adamar Adamar Oct 05, 2009 at 21:07 UTC - 0 likes

    To fix this simply do the following:

    Uninstall the application from add/remove programs and/or to delete the ClickOnce app store and get back to clean state.

    To delete the ClickOnce app store, click the Windows start button, and select Run. Enter "%userprofile%\Local Settings\Apps" and click OK Delete the 2.0 folder.

  • 2 comments

Facts

Last updated
Oct 05, 2009
Reported
Oct 05, 2009
Status
Verified - QA has verified that the fix has worked.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees